2 - OpenCPN 3.3.x. Beta

This is the Bug Report tracker for the latest OpenCPN - beta development version.
Please add Feature Requests to the 'OpenCPN - Feature Requests' project - thanks.
Also ensure that you have installed the LATEST beta version 3.3.xxx before adding any faults or bugs to the tracker - thanks!
Tasklist

FS#512 - Localization Visiting Toolbox/Languages tab causes bogus entries in log file

Attached to Project: 2 - OpenCPN 3.3.x. Beta
Opened by Fabbian Dufoe (fgd3) - Sunday, 05 June 2011, 10:19 GMT-7
Last edited by Serge Davenel (AISEAG) - Thursday, 21 November 2013, 12:37 GMT-7
Task Type Bug Report
Category Backend / Core
Status Closed
Assigned To No-one
Operating System All
Severity Low
Priority Normal
Reported Version 1.0
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Visiting the Languages tab in the toolbox causes these error messages to be emitted to the log file.

12:53:57: Error: Cannot set locale to language Arabic (Uae).
¤U¤È 12:53:57: Error: Cannot set locale to language Chinese (Hongkong).
¤U¤È 12:53:57: Error: Cannot set locale to language Chinese (Macau).

No changes were made to anything in the Languages tab.
This task depends upon

Closed by  Serge Davenel (AISEAG)
Thursday, 21 November 2013, 12:37 GMT-7
Reason for closing:  Implemented
Comment by Fabbian Dufoe (fgd3) - Tuesday, 07 June 2011, 06:00 GMT-7
The two Chinese entries seem to be fixed in build 606, but visiting the Languages tab still causes "08:54:15 Eastern Daylight Time: Error: Cannot set locale to language Arabic (Uae)." to be written to the log file. This happened even though I visited the Languages tab and then clicked "Cancel".

Fabbian
Comment by Gunther (Netsurfer) - Tuesday, 07 June 2011, 06:36 GMT-7
I can confirm this.
Entry on a German version looks like:
15:33:20 Mitteleuropäische Sommerzeit: Error: Cannot set locale to language Arabic (Uae).

Further more we could save a lot of bytes if we would just use "MESZ" instead of "Mitteleuropäische Sommerzeit" ... ;-)

Gunther
Comment by Dave (bdbcat) - Saturday, 11 June 2011, 19:52 GMT-7
Fabbian/Gunther....

This seems to be a wxWidgets bug. If you install Asian language sets on Windows, this error disappears.
Dunno why it complains about Arabic (Uae), though....

Dave
Comment by Fabbian Dufoe (fgd3) - Saturday, 11 June 2011, 21:20 GMT-7
I didn't install any Asian language support between 523 and 606. When I installed 606 the two messages about Chinese (Hongkong) and Chinese (Macau) went away, but the message about Arabic (Uae) remains. That makes me think there are two separate bugs, one of which was fixed in 606. If the wxWidgets version remained the same between 523 and 606 I don't see how it could be a wxWidgets bug.

Fabbian
Comment by Serge Davenel (AISEAG) - Thursday, 12 September 2013, 11:07 GMT-7
  • Field changed: Attached to Project ( → 2 - OpenCPN 3.3.x. Beta)

Previously this bug was reported in OpenCPN 2.6.x beta.

Message from Fabbian :
Thanks for following up on that request. I still get this entry in my log file if I visit the Languages tab in 3.3.814.

19:28:30: Error: Cannot set locale to language Arabic (Uae).

Comment by Dave (bdbcat) - Wednesday, 16 October 2013, 16:20 GMT-7
I cannot reproduce in 3.3.1009.

Anyone have any hints?

Dave
Comment by Fabbian Dufoe (fgd3) - Saturday, 19 October 2013, 08:33 GMT-7
I thought 3.3.1006 was the latest Beta. Anyway, that's the latest one I found and the problem still exists. I've attached an excerpt from the log file. I launched 3.3.1006 twice. The first time I did not do anything but wait for it to open, then exit. The second time I visited the toolbox, went to the User Interface tab, cancelled, and exited the program. In the log of the second launch you'll find the line "11:29:30: Error: Cannot set locale to language Arabic (Uae)." So this is still a reproducible bug.

Fabbian

Loading...