Home    Downloads    Beta Testing

Beta Testing

Testing is Active once more.

Beta Version 4.5.221 is available for download.

Download directly:
http://opencpn.navnux.org/beta/opencpn_4.5.221_setup.exe
http://opencpn.navnux.org/beta/OpenCPN_4.5.221.dmg

Source is available now on github at:
https://github.com/OpenCPN/OpenCPN
Branch: master
Tag: Beta_v4.5.221

4.5.221 Beta Release Notes

41.  Add ENC Text tool "A+" to iENC mode, Remove "Zoom+" and "Zoom-"
42.  Disable hiding of iENC toolbar
43.  Correct several elements of iENC toolbar rendering.
44.  Improved DC (non-GL) quilted text rendering.
45.  Improved vector chart zoom slider interaction with "Reduced Detail at small scale" option.
46.  Correct legacy ENC Plugin display (e.g.S63)
47.  Adjust default configuration settings for better initial ENC display.
48.  Establish 'N' as hotkey to return to Standard display in iENC mode.

Comments:
1.  Please check your Flyspray tasks, and clear if possible.
2.  Consider this Beta to be the "last call" for language updates on the crowdin site.  Let me know if any strings are missing or untranslatable.
3.  It is now time to check carefully (again) the special Inland ENC mode for compliance with the specification.  I believe the GUI aspect is complete. Now we should be concerned with general usability and rendering fidelity.
Thanks
Dave

icon  Windows

OpenCPN 4.5.221 for Windows® XP SP3/Vista/7/8/8.1/10

[Download]

icon Mac

OpenCPN 4.5.221 for Mac OS X 10.7+

[Download]

icon

For Ubuntu Linux and it's derivatives (Linux Mint) and Debian Jessie based distributions, OpenCPN is distributed from a Ubuntu Beta PPA.
If you're not sure how to add the repository to your system, read the chapter Configuring Ubuntu PPA in the user manual.

icon

Pending

icon

For Debian derivatives, you can use the same packages as for some Ubuntu releases.
Debian Oldstable (Wheezy)  You can use the packages from the Ubuntu Beta PPA.

The compatible Ubuntu Release is Lucid.  Unfortunately we can't add new Lucid builds to the PPA anymore due to it being obsolete.  If you need newer plugins, you may try to use Precise packages instead.  (You will most likely also need to upgrade your libc6 to version 2.15 or newer, so please consider switching to Jessie completely.)
Debian Stable (Jessie)  You can use the packages from the Ubuntu PPA mentioned above.  The compatible Ubuntu Release is Trusty.

icon

Pending

icon

Pending


Site Policy          ©  2009 -   OpenCPN.org           Contact           Donate